Top > OOoBasic > Macros > MRI > Documentation > Installation

インストール Edit

インストール Edit

MRI 0.4.0

  • 必要環境: OpenOffice.org 2.x 系、Py-UNO、Python 2.3.4

インストールはツール - 拡張機能マネージャから行います。インストール終了後に一度 OpenOffice.org を再起動してください。クイック起動も一度停止させる必要があります。

MRI 0.5.0

  • 必要環境: OpenOffice.org 2.4 系、Py-UNO、Python 2.3.4

OpenOffice.org 2.0 - 2.3 を利用しているのであれば 0.4.x を使用してください。

MRI.oxt パッケージのインストールはメニューのツール - 拡張機能マネージャから行ってください。

インストール終了後に一度 OpenOffice.org を再起動してください。クイック起動も一度停止させる必要があります。

Py-UNO ブリッジをインストールしていなければ次のようなエラーメッセージが表示されます。Python-UNO

"ImplementationRegistration::registerImplementation() - The service com.sun.star.loader.Python cannnot be instantiated"

次のようなエラーが表示された場合には OpenOffice.org のインストールに問題があります。
"(com.sun.star.uno.RuntimeException){{Message = "pythonloader: couldn't find core element pythonloader.Loader", Contex = (com.sun.star.uno.XInterface) @0}}

アップデート Edit

アップデートは古いパッケージをツール - 拡張機能マネージャから削除、OOo を再起動した後で新しいパッケージをインストールしなおしてください。これを行わないときにはエラーが出ることがあります。

アップデートは次のような手順で行います。

  1. MRI およびドキュメントを閉じる
  2. 旧バージョンの MRI を拡張機能マネージャから削除する
  3. OpenOffice.org を再起動する (クイックスタートも終了させます)
  4. 新しいバージョンの MRI を拡張機能マネージャからインストールする
  5. OpenOffice.org を再起動する

新しいバージョンの MRI をインストールする前に再起動しなかった場合には次のような例外ダイアログが表示されます。

installation-exception.png

このような例外が表示されたときには MRI を削除したのち OpenOffice.org を再起動してください。

エラーが解決しないときには次の手順を試してみてください。

  1. MRI が残っておれば拡張機能マネージャから削除します
  2. OpenOffice.org を再起動します
  3. 拡張機能マネージャを開いてツリーを展開させます
  4. 再度 OpenOffice.org を再起動させます
  5. MRI をインストールセクションにしたがってインストールします

OpenOffice.org 2.4 以降では古いパッケージを上書きアップデートできます。

アンインストール Edit

アンインストールは、ツール - 拡張機能マネージャから行ってください。


Attach file: fileinstallation-exception.png 239 download [Information]

Reload   New Lower page making Edit Freeze Diff Upload Copy Rename   Front page List of pages Search Recent changes Backup   Help   RSS of recent changes